Friday, May 30, 2008

Configuring Cisco HWIC-3G

Some people asked me about configuring HWIC-3G-GSM or HWIC-3G-CDMA module. To read more information about these modules, you can open this link http://www.cisco.com/go/3g

Basically, Cisco 3G Wireless WAN HWIC provides a cost-effective alternative to ISDN dial back up and provides Business Continuity for critical applications.
  • Offers Broadband data rates up to 3.2 Mbps with EVDO and 3.6 Mbps with HSDPA
  • Supports CDMA and GSM/UMTS standards (EVDO Rev A / HSDPA)
  • Target Applications – WAN Backup, Rapid Deployment, Portable Applications
  • Supported on Cisco 1841 / 2800 / 3800 Series Routers
  • Embedded mini PCI express Cellular modem from Sierra Wireless
  • Modem firmware is upgradeable, it is not bundled with IOS
  • Multiple external antenna options for in-building deployments

Firmware

Sierra Wireless modem firmware is not bundled with IOS. Modem firmware upgrade may be required for bug fixes and enhancements

Search for new firmware here: http://www.cisco.com/kobayashi/sw-center/sw-wireless.shtml

IOS Commands to upgrade firmware:
microcode reload cellular cdma modem-provision
where pa-bay is 0 for HWIC, slot is the slot number where the 3G HWIC is plugged in (0-3).

Note: The firmware is packaged as a TAR archive. After copying to router flash, use the following command to untar:
archive tar /xtract flash: flash:


HWIC Insertion and Recognition


Router#show version

1 Virtual Private Network (VPN) Module

1 Cellular interface

DRAM configuration is 64 bits wide with parity enabled.
479K bytes of NVRAM.


Router#show diag
WIC Slot 0:
3G WWAN HWIC-HSDPA/UMTS/EDGE/GPRS-850/900/1800/1900/2100MHz
...
Product (FRU) Number : HWIC-3G-GSM
Version Identifier : NA

Router#show run
!
interface Cellular0/0/0
no ip address
shutdown
!



Profile Configuration CLI


Up to 16 Profiles can be configured at one time, when no profile is selected, profile 1 is used.

GSM Profile configuration command:
cellular x/x/x gsm profile create [chap|pap] username passwd
cellular x/x/x gsm profile delete


Profile Selection
Using “ATDT*98*#”in the dialer chat script

Router# cellular 0/0/0 gsm profile create 1 ISP.CINGULAR chap ISP@CINGULARGPRS.COM CINGULAR1

Profile 1 = INACTIVE*
--------
PDP Type = IPv4, Header Compression = OFF
Data Compression = OFF

Access Point Name (APN) = ISP.CINGULAR

Authentication = PAP

Username: ISP@CINGULARGPRS.COM, Password: CINGULAR1



New Cellular Interface configuration

The new Cellular interface is an Async Serial interface and requires following configuration

PPP Configuration
encapsulation ppp
ppp chap hostname
ppp chap password
ppp ipcp dns request


Dialer Configuration:
async mode interactive
dialer in-band

IP Address configuration
ip address negotiated

Sample Configuration:

interface Cellular0/0/0
ip address negotiated
ip nat outside
encapsulation ppp
dialer in-band
dialer string gsm
dialer-group 1
async mode interactive
ppp chap hostname dummy
ppp chap password 0 dummy
ppp ipcp dns request
!


Dialer/Chat Scripts


ATDT*98*#
where profile-number could be 1-16 and represents
the modem profile to be used for the call.

Example chat script:
chat-script gsm “” “ATDT*98*2#” TIMEOUT 30 CONNECT

For default Profile 1, profile number can be left out in the chat script:
chat-script gsm “” “ATDT*98#” TIMEOUT 30 CONNECT



Configuration Examples














Here we have the 3G as the primary connection, we use Dynamic IP Address and the Router acting as a DHCP server. The laptop connects to the router via wireless, in the router we have HWIC-AP module installed.

dot11 ssid test
authentication open
!
ip dhcp pool wlan-client
network 10.4.0.0 255.255.0.0
default-router 10.1.0.1
dns-server 66.102.163.231 66.102.163.232
!
chat-script gsm "" "ATDT*99#" TIMEOUT 60 "CONNECT"
!
interface Dot11Radio0/2/0
no ip address
!
ssid test
!
bridge-group 104
!
interface Cellular0/0/0
ip address negotiated
ip nat outside
encapsulation ppp
dialer in-band
dialer string gsm
dialer-group 1
async mode interactive
ppp chap hostname cisco@wwan.ccs
ppp chap password 0 cisco
ppp ipcp dns request
!
interface bv1
ip address 10.4.0.1 255.255.0.0
ip nat inside
!
ip route 0.0.0.0 0.0.0.0 Cellular0/0/0
!
ip nat inside source list 10 interface Cellular0/0/0 overload
!
access-list 1 permit any
dialer-list 1 protocol ip list 1
!
line 0/0/0
exec-timeout 0 0
script dialer gsm
login
modem InOut
no exec
!



11 comments:

Anonymous said...

Hi,

I've just got a 3G HWIC, and followed your instructions although I can't get the device to dial.

I've got a machine connected via FastEthernet0/0 which gets an IP by DHCP for the 1841, and it is NATted via Cellular0/0/0 however the device doesn't seem to dial, and there is no console output at all.

Any ideas?

Cheers,
-Jeff

Bayu Prasidha Wibowo said...

@Jeff:
Hi Jeff, i don't really get what is your problem, have you read the documentation at cisco.com here http://www.cisco.com/en/US/docs/routers/access/1800/1861/software/feature/guide/3ghwic.html ?
Make sure your card is ready for online.
I don't have the 3G HWIC right now, maybe next month after I got the 3G HWIC I'll update my blog here with the clearer explanation.
Thanks.

Anonymous said...

Thanks for you posting. Have you encounter cell interface went down every hour? I having this issue with the following message.

%LINEPROT-5_UPDOWN Line protocol on Interface Cellular0/0/0 changed state to down.

I lost connectivity and then it will come backup.

Greatly appriciated for any input to this annoying problem.

Thanks

Bayu Prasidha Wibowo said...

@anonymous:
have you debug the cellular interface?

try to debug these:
● debug dialer
● debug chat
● debug ppp negotiation
● debug ppp error
● debug ppp event
Note: This debug requires that you have enable service internal enabled.

If you see TERMREQ as shown in the following debugs, it implies that the service provider is terminating the call:
Jul 20 19:15:31 UTC: Ce0/0/0 LCP: I TERMREQ [Open] id 68 len 4
*Jul 20 19:15:31 UTC: Ce0/0/0 LCP: O TERMACK [Open] id 68 len 4
*Jul 20 19:15:31 UTC: Ce0/0/0 PPP: Sending Acct Event[Down] id[1A]
*Jul 20 19:15:31 UTC: Ce0/0/0 IPCP: State is Closed
To troubleshoot further, shut down all other interfaces except the cellular interface and issue a ping from the router. If the ping succeeds, reconfigure other interfaces one by one and verify what traffic escapes the access lists or NAT to cause the service provider to terminate the call.

further readings click here and search for keyword flapping

hope this helps

Anonymous said...

Check with your cellular provider. Mine reset every 12 hours when checking with the cellular support people. I found out it is done purposely from the cell network to cut accounting records.

GL said...

Hi,

attending to your instructions, it would seem that it's required to configure the APN, username and password provided by the Service Provider. I guess this is natural if you want access to Internet. But what about just creating a private point-to-point tunnel between two routers of mine (both equipped with the HWIC 3G)? Is it possibile to establish a connection just dialing the mobile phone number of the receiving SIM card?

Anonymous said...

hello professionals ,
I really need some help ,I have a cisco HWIC-3G-CDMA-S card and I want to change the MNC(Mobile Network Code ) and MCC (Mobile Country Code) to match the one that our wireless carrier provides,but I don’t know which command does that.I have been trying to solve this problem for a month and I really need help .I have searched in cisco website but I couldn’t find anything useful .by the way it is our carrier who told us to change MCC and MNC to match the one they provide.
I would be grateful if you help me.

this is my email:
hasan.selwi@smartnet-yemen.com

sociallyawkward said...

Hi there,
im having an issue with a 2811 not recognising the 3g hwic(sh daig). it running advent 124.22 T1.I've got another router working fine with the same ios...
pls advise

thanks
Sfiso

Unknown said...

Thanks for sharing this information . you saved me a lot of work.

Video Conference UK

Herald Setiadi M.Kom said...

Pak Bayu,

Do you know username and password PPP Connection if I using ISP Telkomsel (Simpati card)

Herald Setiadi M.Kom said...

Hi Bayu,

Do you what is the configuration if I use Telkomsel Simpati for PPP Connection?I mean what is the username dan password for PPP?